Call quality issues

#1
Hi, I use a Cisco SPA112 VoIP Adaptor and 2 sets of DECT phones with Voipfone.

I'm currently having call quality issues where voices drop in & out - there are very short intermittent silences such that sometimes you miss 1 word out of 3.

I do regularly get call quality issues when there is a lot of traffic on my network - people sound like robots & break up substantially - but that's occasional, it doesn't happen all the time and is remedied by turning off PCs. This new problem seems to be happening all the time, even when there are no other devices connected to the network.

Please can anyone suggest how I might be able to resolve this?

Many thanks in advance
Andy

Re: Call quality issues

#2
Sounds like a bandwidth issue to me. Is the issue present on both inbound and outbound audio? What speeds do you get when running a speed test?

Also, run a VoIP test from here: http://myspeed.visualware.com/index.php and post back with the results.

In the meantime there are a few things you can do... Disable SIP ALG on your router and setup QOS giving SPA112 the highest priority. (No need to turn off your PC's then)

We could try changing the Codec on your SPA112, I take it your currently using G.711A? Did you purchase you SPA112 from Voipfone?
For everything VoIP
www.ukvoipforums.com

Re: Call quality issues

#3
Hi Paul, thanks for the reply.

Answers to your questions (that I can answer!) below...
WelshPaul wrote:Is the issue present on both inbound and outbound audio?
Yes
WelshPaul wrote:What speeds do you get when running a speed test?
Speedtest.net says 29 Mbps download, 2.9 Mbps upload. It's Virgin 'up to 50 Mbps' cable broadband.
WelshPaul wrote:Also, run a VoIP test from here: http://myspeed.visualware.com/index.php and post back with the results.
I couldn't see a 'run test' button on that site so I assume I need to download & run MyConnectionServer software? I did that, and had a guess at which test I should run (I picked Voip SIP ALG, no idea if that's right) - results seem ok:
Image
WelshPaul wrote:In the meantime there are a few things you can do... Disable SIP ALG on your router and setup QOS giving SPA112 the highest priority. (No need to turn off your PC's then)
Do you know if that's possible with a Virgin Super Hub router? I went into the settings and couldn't find any obvious way of doing it...
WelshPaul wrote:We could try changing the Codec on your SPA112, I take it your currently using G.711A? Did you purchase you SPA112 from Voipfone?
I've no idea what G.711A is I'm afraid... but yes it came from Voipfone all set up and ready to go.

Thanks again
Andy

Re: Call quality issues

#4
The results you posted are good however your upload speed is likely going to cause you some issues. 3MB isn't a lot so I strongly recommend you take advantage of QOS (as mentioned in my previous post) so that your SPA112 has priority on your network, that way if someone uses the computer while your on a call your not going to encounter any call quality issues.

Regarding the Virgin Media super hub - I think there are now three different superhubs in circulation, sadly the super hubs are restrictive and don't work well with VoIP. There is no QOS on the superhub and you cannot disable SIP ALG...

You can however put the VM super hub in modem only mode and use your own router with it (I do this), this is what VM recommend you do. Make sure any router you go with has QOS and that SIP ALG can be disabled, avoid Virgin Superhubs, BT HomeHubs and Friz Box modem/routers. TelNet commands must be used to disable SIP ALG on Technicolor, Thomson, SpeedTouch, some Draytek and some ZyXEL routers.

A £30 Netgear should do the job! Personally I use an ASUS AC68U with a super hub v1 in modem only mode and this works well for me.

G.711A is one of the codecs Voipfone support and the chances are this is the codec your SPA112 is configured to use as the primary codec, we could change this to GSM as it uses less bandwidth however the test result above tells use we do not need to do this. The reason why I asked if you purchased your SPA112 from Voipfone was because they provision your device remotely, any changes you make to the devices configuration may get overwitten by the Voipfone provisioning server. You will need to disable auto provisioning on the SPA112 to prevent this from happening.
For everything VoIP
www.ukvoipforums.com

Re: Call quality issues

#5
Paul

Firstly can I say thanks for your helpful and detailed reply. From this and reading other forum posts it did sound like I needed a new router. So I bought a TP-LINK WR1043ND. Unfortunately after much faffing I've been unable to get this working with my Virgin Superhub (which btw is a first-generation superhub I think, from the look of it). The router just would not find the Virgin modem when in 'modem mode', it couldn't see the WAN or get any IP details from it. I expect this is an issue with the modem, as intermittently I couldn't get the laptop to connect in modem mode either, it seemed hit & miss.

Anyway, whilst in the advanced settings of the Virgin superhub I came across a "SIP ALG" setting (in the "firewall" menu). I've also read in other places that the superhub does not contain this feature, so I was surprised to see it. Maybe it was added in a firmware upgrade at some point.

I unticked SIP ALG and delighted to say that - so far - VOIP connections have dramatically improved. This has made a staggering difference and I can now use the PC and make a phone call at the same time no problem.

So the WR1043ND is going back, I don't feel it's worth carrying on trying to get that working just for the QoS feature as I'm now totally satisfied with call quality just from the SIP ALG change.

Thanks again

WelshPaul wrote:The results you posted are good however your upload speed is likely going to cause you some issues. 3MB isn't a lot so I strongly recommend you take advantage of QOS (as mentioned in my previous post) so that your SPA112 has priority on your network, that way if someone uses the computer while your on a call your not going to encounter any call quality issues.

Regarding the Virgin Media super hub - I think there are now three different superhubs in circulation, sadly the super hubs are restrictive and don't work well with VoIP. There is no QOS on the superhub and you cannot disable SIP ALG...

You can however put the VM super hub in modem only mode and use your own router with it (I do this), this is what VM recommend you do. Make sure any router you go with has QOS and that SIP ALG can be disabled, avoid Virgin Superhubs, BT HomeHubs and Friz Box modem/routers. TelNet commands must be used to disable SIP ALG on Technicolor, Thomson, SpeedTouch, some Draytek and some ZyXEL routers.

A £30 Netgear should do the job! Personally I use an ASUS AC68U with a super hub v1 in modem only mode and this works well for me.

G.711A is one of the codecs Voipfone support and the chances are this is the codec your SPA112 is configured to use as the primary codec, we could change this to GSM as it uses less bandwidth however the test result above tells use we do not need to do this. The reason why I asked if you purchased your SPA112 from Voipfone was because they provision your device remotely, any changes you make to the devices configuration may get overwitten by the Voipfone provisioning server. You will need to disable auto provisioning on the SPA112 to prevent this from happening.

Re: Call quality issues

#6
Thanks for the update Andy, nice to hear that VM have added the SIP ALG option to the super hub.

I know your sending back the TP-LINK router but just a heads up - when putting the super hub in modem only mode you have to use the ethernet port that is closest to the coax/power supply. The first three ethernet ports are disabled and useless in modem only mode.

Happy VoIPing Andy
For everything VoIP
www.ukvoipforums.com

Re: Call quality issues

#7
WelshPaul wrote:when putting the super hub in modem only mode you have to use the ethernet port that is closest to the coax/power supply. The first three ethernet ports are disabled and useless in modem only mode.
Yup that's the only one I used, Virgin have made quite clear on the admin page that that's the one you can use, but it didn't work for me. I assume a hardware fault. - I'll probably decide at some point that I want the extra features a new router would provide and get in touch with Virgin technical help to get it sorted out, and presumably get the superhub swapped. But at the moment I'm taking the stance of 'ain't broke don't fix it' and avoiding the pain of a prolonged phone call to a Virgin call centre!

Cheers.

Who is online

Users browsing this forum: No registered users and 0 guests

Copyright 2004 - 2017, iNet Telecoms® Ltd. All rights reserved.


cron