Cisco 7960 call resume fail

#1
Hi

We've been having a knightmare for months now in that we were unable to transfer incoming calls. Upon further investigation we believe that the problem is in actual fact that we are unable to resume calls after being put on hold.

When we receive a call and put it on hold or attempt to transfer the call, and then press to resume, the phone says connected but it fails to do so. The caller is left listening to the on hold music indefinitely.

However, if we make an outbound call and then put them on hold, it resumes fine.

Further info that I have tried or may help diagnose:

- I have tried a Belkin and Linksys router with phones connected directly
- Tried 3 different Cisco 7960 SIP phones
- Confirmed the outbound proxy on the phone is sip.voipfone.co.uk
- Tried outbound proxy set to nat.voipfone.co.uk:5065

I've seen the post below however we cannot manage with just a blind transfer facility.

viewtopic.php?f=4&t=2252&p=13169&hilit=transfer#p13169

Any help or tips would be really appreciated.

Thanks
Matt

Re: Cisco 7960 call resume fail

#4
We are aware transfer does not currently work on some of the Cisco phones on our service. We are making changes which should enable this in the coming weeks.

In the mean time if you have your DTMF method set to RFC2833 then you can use:

## extension to do a blind transfer
#1 to place a call on hold, # to resume the call from hold
Regards,

Voipfone Customer Services

iNet Telecoms Ltd (Voipfone)
Sovereign House
227 Marsh Wall
London
E14 9SD
United Kingdom

Registered number: 05168033
Vat Registration Number 858850966

Telephone: 020 7043 5555
Fax: 020 7043 5556

Web: http://www.voipfone.co.uk
Blog: http://www.voipfoneblog.co.uk
Forum: http://www.voipfoneuserforum.co.uk
Twitter: http://www.twitter.com/voipfone

Re: Cisco 7960 call resume fail

#5
Can you be more specific with the date please as to when the problem 'should' be fixed? We have been experiencing this for 3+ months now and it appears others may have suffered for longer.

We are regularly adding to our phone network and need confidence that voipfone will resolve this matter.

Thanks

Re: Cisco 7960 call resume fail

#6
We can only guarantee that the phones we sell ourself will work fully with our network; although we do our best to support any phone conforming to SIP standards.

However, we hope to be introducing new load balancing software at the weekend which should sort out your problem.
Regards,

Voipfone Customer Services

iNet Telecoms Ltd (Voipfone)
Sovereign House
227 Marsh Wall
London
E14 9SD
United Kingdom

Registered number: 05168033
Vat Registration Number 858850966

Telephone: 020 7043 5555
Fax: 020 7043 5556

Web: http://www.voipfone.co.uk
Blog: http://www.voipfoneblog.co.uk
Forum: http://www.voipfoneuserforum.co.uk
Twitter: http://www.twitter.com/voipfone

Re: Cisco 7960 call resume fail

#8
Yes, it's in test now. if you'd like to try it change your registrar from sip.voipfone.co.uk to sip.voipfone.net

Please tell us if it works for you.
Regards,

Voipfone Customer Services

iNet Telecoms Ltd (Voipfone)
Sovereign House
227 Marsh Wall
London
E14 9SD
United Kingdom

Registered number: 05168033
Vat Registration Number 858850966

Telephone: 020 7043 5555
Fax: 020 7043 5556

Web: http://www.voipfone.co.uk
Blog: http://www.voipfoneblog.co.uk
Forum: http://www.voipfoneuserforum.co.uk
Twitter: http://www.twitter.com/voipfone

Re: Cisco 7960 call resume fail

#11
Scratch that success ..... it was very short lived.

I tested it as i was finding that it wasn't so much the transfer that wasn't working but the resume function.

I just tried the new setting as suggested and i called the cisco phone and put the call on hold, got the music, and then successfully resumed.

I then tried to transfer a call and although i didn't pick up the line i was sending to, i successfully ended that call and resumed the original.

I have just tried all that again and i am back to where i started, unable to resume a call that has been put on hold.

:evil:


But hang on ...... whilst writing this i've spotted that the outbound proxy didn't save to sip.voipfone.net ........ watch this space

Re: Cisco 7960 call resume fail

#13
running commentary continues .....

i edited the SIPDefault.cnf file from :

# Outbound Proxy info
# outbound_proxy: "sip.voipfone.co.uk"
# outbound_proxy_port: "5060"
outbound_proxy: "sip.voipfone.co.uk"
outbound_proxy_port: "5060"

To this:

# Outbound Proxy info
# outbound_proxy: "sip.voipfone.net"
# outbound_proxy_port: "5060"
outbound_proxy: "sip.voipfone.net"
outbound_proxy_port: "5060"

The phone happily took the new settings but calls would not work. When making a call on the Cisco the message read 'Calling (in INV)' instead of calling in 'Calling (in 100)'. The phone therefore just diverted to the answer phone.

I then reverted the SIPDefault.cnf back to .co.uk, restarted the phone and I could make and receive calls again.

I then edited the Outbound Proxy on the phone instead by going to Settings > SIP Configuration > Outbound Proxy and set it to sip.voipfone.net and saved. I did not restart the phone.

I have now just tested the call transfer / resume fully and it works ok.

I now need to figure out why flashing it with the edited SIPDefault.cnf file doesn't achieve the same thing.

I'm no techy, i can edit settings and following instructions ..... but i know a man that maybe able to shed some light! Above is just a temporary fix in my mind.

ps oxcis, assuming this is what you are after from SIPDefault.cnf, NAT settings are:

# NAT/Firewall Traversal
nat_enable: "1"
nat_address: "nat.voipfone.co.uk"
nat_received_processing: "1"
voip_control_port: "5065"
start_media_port: "16384"
end_media_port: "32766"

Re: Cisco 7960 call resume fail

#14
Changing the settings straight on the phone was a genius idea - nice one Matt. It made me wonder if it was a boot up sequence DNS issue. Either way I changes the SIPDefault.cnf file to the following and rebooted the phone - all works wonderfully:

image_version: "P0S3-8-12-00" ; SIP Version 8.12

# NAT/Firewall Traversal voip control port default 5065

nat_enable: "1"

nat_address: "nat.voipfone.co.uk"

nat_received_processing: "1"

voip_control_port: "5065"

start_media_port: "16384"

end_media_port: "32766"


# Proxy Server info Resolves to 195.189.173.10

proxy1_address: "sip.voipfone.co.uk"

proxy1_port: "5060" ; Proxy Server Port (default - 5060)

proxy_register : 1


# Outbound Proxy info Resolves to sip.voipfone.net

outbound_proxy: "195.189.173.151"
outbound_proxy_port: ""

Re: Cisco 7960 call resume fail

#17
Glad you got it working.

Please be aware that this is on a test network - it's not fully live so some features may not work. Call Recording is the only one we are aware of so far; it's not a bug it's just that the test network doesn't connect with that service and won't until we switch IP address when it goes live.

when we switch to the live service, you don't have to change anything, it will carry on working as it is now.
Regards,

Voipfone Customer Services

iNet Telecoms Ltd (Voipfone)
Sovereign House
227 Marsh Wall
London
E14 9SD
United Kingdom

Registered number: 05168033
Vat Registration Number 858850966

Telephone: 020 7043 5555
Fax: 020 7043 5556

Web: http://www.voipfone.co.uk
Blog: http://www.voipfoneblog.co.uk
Forum: http://www.voipfoneuserforum.co.uk
Twitter: http://www.twitter.com/voipfone

Re: Cisco 7960 call resume fail

#19
On second thoughts, it would be good practice to change your registrar back to sip.voipfone.co.uk once we put the new balancer live.

Because sip.voipfone.net is a test network, someone may well change something on it at any time and we'd all be scratching our heads trying to work out why your phones have suddenly developed faults ......

We'll let you know when it's live.
Regards,

Voipfone Customer Services

iNet Telecoms Ltd (Voipfone)
Sovereign House
227 Marsh Wall
London
E14 9SD
United Kingdom

Registered number: 05168033
Vat Registration Number 858850966

Telephone: 020 7043 5555
Fax: 020 7043 5556

Web: http://www.voipfone.co.uk
Blog: http://www.voipfoneblog.co.uk
Forum: http://www.voipfoneuserforum.co.uk
Twitter: http://www.twitter.com/voipfone

Re: Cisco 7960 call resume fail

#21
We plan to migrate the test network to the production platform on Monday night - 7th Feb.

This will unregister your phones for about 10 minutes - possibly much less. If they don't come back up, please reboot them.
Regards,

Voipfone Customer Services

iNet Telecoms Ltd (Voipfone)
Sovereign House
227 Marsh Wall
London
E14 9SD
United Kingdom

Registered number: 05168033
Vat Registration Number 858850966

Telephone: 020 7043 5555
Fax: 020 7043 5556

Web: http://www.voipfone.co.uk
Blog: http://www.voipfoneblog.co.uk
Forum: http://www.voipfoneuserforum.co.uk
Twitter: http://www.twitter.com/voipfone

Re: Cisco 7960 call resume fail

#23
We also plan to start work on updating the TAPI on Monday.

If you have any ideas/requirements/suggestions/demands - now would be a good time to raise them.

Please reply in the TAPI forum.
Regards,

Voipfone Customer Services

iNet Telecoms Ltd (Voipfone)
Sovereign House
227 Marsh Wall
London
E14 9SD
United Kingdom

Registered number: 05168033
Vat Registration Number 858850966

Telephone: 020 7043 5555
Fax: 020 7043 5556

Web: http://www.voipfone.co.uk
Blog: http://www.voipfoneblog.co.uk
Forum: http://www.voipfoneuserforum.co.uk
Twitter: http://www.twitter.com/voipfone

Re: Cisco 7960 call resume fail

#24
Just a note for those using the IP address to register and not the domain of sip.voipfone.net. The IP for sip.voipfone.net is now 195.189.173.27.

Ideally don't register to the IP, instead use the domain.
Regards,

Voipfone Customer Services

iNet Telecoms Ltd (Voipfone)
Sovereign House
227 Marsh Wall
London
E14 9SD
United Kingdom

Registered number: 05168033
Vat Registration Number 858850966

Telephone: 020 7043 5555
Fax: 020 7043 5556

Web: http://www.voipfone.co.uk
Blog: http://www.voipfoneblog.co.uk
Forum: http://www.voipfoneuserforum.co.uk
Twitter: http://www.twitter.com/voipfone

Who is online

Users browsing this forum: No registered users and 0 guests

Copyright 2004 - 2017, iNet Telecoms® Ltd. All rights reserved.


cron