Nokia N900

#1
Has anyone managed to configure an N900 to use Voipfone?

The configuration dialogue is not very clear as to what is supposed to be entered and the manual is useless. I've tried all possible and sensible permutations and the best so far is a message saying either the username or password is incorrect which suggests some level of connectivity.

I've read elsewhere in this forum that N series phones have a problem making SIP calls so maybe I should wait for a patch to come out; which seems to be happening every couple of days. I appreciate the difference between a Symbian and Maemo device.

Ta.

Re: Nokia N900

#2
I can't get mine to work with Voipfone, it connects OK but I get no incoming audio, though outgoing is OK. If I use my ixcall account it works perfectly.

It's rather irritating as I'd like to make SIP calls over Wifi both at home and at cafes.

Re: Nokia N900

#3
From other forums it's clear that the SIP client works and obviously Voipfone works. The problem is the labels for the various fields are not at all clear as to what should be entered and the documentation is useless.

I've had at least two updates to the SIP client now. At one stage there was two places to put a username. At least that's changed to one.

I'm very disappointed with the N900. The sync is nowhere near as good as the old Palm Treo, even with it's own desktop app. You can't make calls to the network using the # numbers. The email client wants to download all 32GB in my email folder. But, as a handheld Linux device, it's great!

Re: Nokia N900

#4
I have the same problem (outgoing audio is fine, incoming is broken) too even with the PR1.2 firmware.

Has anyone else managed to make the n900 work with voipfone?

Is this some weird codec issue that perhaps disabling some of the codecs might help with?

Re: Nokia N900

#6
I'll put the field name then a : then a list of some of the options I've tried
Address: 3xxxxxxx@sip.voipfone.co.uk or 3xxxxxxx@195.189.173.10
Password: *********
Username: 3xxxxxxx or blank
Transport: UDP or auto (also has TLS & TCP)
I'll combine Outbound proxy and Port here for convenience though on the phone they are separate fields

Outbound proxy/port: sip.voipfone.co.uk:5060 or nat.voipfone.co.uk:5065 or 195.189.173.12:5065 or 195.189.173.10:5060

Discover public address: on or off
Loose routing: on or off
Keep-alive mechanism: auto (also has REGISTER, OPTIONS & off)
Keep-alive period: Auto (also has 30sec, 1min, 2min, 15min & 60min)
Auto-detect STUN: on or off
if STUN auto detection is off 2 extra fields STUN server and STUN port appear, I've tried Auto on or Auto off and leaving them blank, or I've put in a public STUN server.

So far it either connects fine but I get the dredded one way audio or with some permutations it won't even connect.

ixcall works fine.

Re: Nokia N900

#8
I'll do some experimentation when I get home, at the moment I'm in Italy where the Alice broadband appears to block all sip connections, can't even get ixcall to connect on my PC, I'm reduced to using Sykpe (yuck).

If I lived here it would irritate the hell out of me.

Re: Nokia N900

#10
Success!

The new details provided by the great voipfone support team for the new system that is currently *being tested* worked a treat on my N900 (as well as clearing up problems between my Belkin Router/Snom M3 combo) for all extensions, from behind a NAT, with 'latest Maemo updates' (PR1.3, I think).

I now have clear two-way audio on both the M3 and the N900.

-- N900 settings --
Address: 30******([*]ext)@sip.voipfone.net
Password: extension or account password

-- Advanced SIP settings--
Check 'Use for telephone numbers'
Username: 30******([*]ext)
Transport: UDP
Outbound proxy: (blank)
Discover public address (checked)
Loose routing (unchecked)
Keep-alive mechanism (auto)
Keep-alive period (auto)
Auto-detect STUN (unchecked)

Hope that helps.

Luke

PS - it even connects over 2G, although it's very patchy. Still good to see it connect.

Who is online

Users browsing this forum: No registered users and 0 guests

Copyright 2004 - 2017, iNet Telecoms® Ltd. All rights reserved.


cron