X-Lite Windows & Ubuntu - 403 forbidden for outbound cal

#1
Hi,

I installed X-Lite on an Ubuntu linux laptop and setup the software as per the user guide. The softphone registered successfully and the display shows "Logged In - Enter Phone Number", underneath that is "Your number is xxxxxxx".

I am able to receive calls but I cannot make outbound. I get "408 timeout" and what sounds like a busy tone.

The Iptables firewall is down.

I then installed the windows version on XP Home and went through the same process and again I can receive calls but when I attempt to make an outbound call I get a slightly different error message, "Call failed 403 Forbidden".

The diagnostic log from the Windows box is as follows and is pretty much the same as the Linux box:

---- snip ---

© 2004 Xten Networks, Inc. All rights reserved.
X-Lite release 1103m build stamp 14262
License key: 908D1ED17BF24E8FBDDE33C2D4BCA325

Established SIP protocol listen on: 192.168.2.14:5060

Discovered Port Restricted Cone NAT Firewall

SIP: 192.168.2.14:5060
RTP: 192.168.2.14:8000
NAT: xx.xxx.xxx.xx

PROXY#0: 195.189.173.10:5060

OUTBOUND-PROXY#0: 195.189.173.12:5065

SEND TIME: 36168781
SEND >> 195.189.173.12:5065
REGISTER sip:sip.voipfone.co.uk SIP/2.0
Via: SIP/2.0/UDP 192.168.2.14:5060;rport;branch=z9hG4bK684BDF5C95784B1BA91F3B8E7AEEF249
From: bloatedstoat <sip>;tag=1729102030
To: bloatedstoat <sip>
Contact: "bloatedstoat" <sip>
Call-ID: 0C63B3473ACD44A88446A5E57F7A5691@sip.voipfone.co.uk
CSeq: 3237 REGISTER
Expires: 1800
Authorization: Digest username="xxxxxxxx",realm="asterisk",nonce="ukkvslcw",response="1332895c244f8a286498eabb94b76ee8",uri="sip:sip.voipfone.co.uk"
Max-Forwards: 70
User-Agent: X-Lite release 1103m
Content-Length: 0


RECEIVE TIME: 36168796
RECEIVE << 195.189.173.12:5065
SIP/2.0 200 OK
Record-Route: <sip>
Record-Route: <sip>
Via: SIP/2.0/UDP 192.168.2.14:5060;received=xx.xxx.xxx.xx;rport=5060;branch=z9hG4bK684BDF5C95784B1BA91F3B8E7AEEF249
From: bloatedstoat <sip>;tag=1729102030
To: bloatedstoat <sip>
Call-ID: 0C63B3473ACD44A88446A5E57F7A5691@sip.voipfone.co.uk
CSeq: 3237 REGISTER
Contact: "bloatedstoat" <sip>;expires=60
Expires: 60
Date: Wed, 07 May 2008 17:32:07 GMT
Min-Expires: 60
User-Agent: Voipfone
Content-Length: 0


SEND TIME: 36228875
SEND >> 195.189.173.12:5065
REGISTER sip:sip.voipfone.co.uk SIP/2.0
Via: SIP/2.0/UDP 192.168.2.14:5060;rport;branch=z9hG4bKF459623534574F7AB4E0450CD52E2A82
From: bloatedstoat <sip>;tag=1729102030
To: bloatedstoat <sip>
Contact: "bloatedstoat" <sip>
Call-ID: 0C63B3473ACD44A88446A5E57F7A5691@sip.voipfone.co.uk
CSeq: 3238 REGISTER
Expires: 1800
Max-Forwards: 70
User-Agent: X-Lite release 1103m
Content-Length: 0


RECEIVE TIME: 36228906
RECEIVE << 195.189.173.12:5065
SIP/2.0 200 OK
Record-Route: <sip>
Record-Route: <sip>
Via: SIP/2.0/UDP 192.168.2.14:5060;received=xx.xxx.xxx.xx;rport=5060;branch=z9hG4bKF459623534574F7AB4E0450CD52E2A82
From: bloatedstoat <sip>;tag=1729102030
To: bloatedstoat <sip>
Call-ID: 0C63B3473ACD44A88446A5E57F7A5691@sip.voipfone.co.uk
CSeq: 3238 REGISTER
Contact: "bloatedstoat" <sip>;expires=60
Expires: 60
Date: Wed, 07 May 2008 17:33:07 GMT
Min-Expires: 60
User-Agent: Voipfone
Content-Length: 0

--- snip ---


I have skype operational on both machines and the software works fine for incoming and outgoing calls.

Anyone got any pointers on what might be the issue?

Thanks.

Who is online

Users browsing this forum: No registered users and 1 guest

Copyright 2004 - 2017, iNet Telecoms® Ltd. All rights reserved.


cron