Mac OSX - X-lite straight to voicemail only

#1
I've been trying to set up X-lite on my Mac to use my geographic UK number. I seem to be having the problem of outgoing calls are fine, but incoming goes straight to voicemail/email.

This appears to be a common error (I get an intermittent 403 error), however I think I have tried the solutions offered here. I have no firewall rules on my Netgear DG834G router/modem enabled. Firewall was off during X-lite installation. No ports have been actively blocked by myself.

In the X-lite account properties I have:

Name - mine
User name - 3+++++++
Password - 6 digit Voipfone
Authorization user name - same as user name
Domain - sip.voipfone.co.uk (I also tried just voipfone.co.uk)

I have also tried entering nat.voipphone.co.uk in the Domain Proxy section address box with "proxy" selected in the 'send outbound via' options. I tried this with both "register with domain" checked and unchecked.

Have I got this right? Or is there something obvious I have missed?

Many thanks.

#3
voipfone wrote:Have you have misspelled 'voipfone' in the NAT proxy? :-)
No, only on the forum! :oops:

I've just again ticked the "Register with domain and receive calls" box, selected 'proxy' out of the 3 options and entered "nat.voipfone.co.uk" in the address box.

As soon as I do this, the phone seeks registration but times out with a 408 error..

Have I entered everything right here and is it time to look for another cause?

Getting a bit lost now... :?

10.5?

#4
Are you running 10.5? There seems to be an insoluble conflict between new x-lite and 10.5 that x-lite blame on Apple. This seems a little disingenuous as other softphones like SJPhone seem to run fine.

SJPhone isn't nearly as pretty, but it does work on 10.5

#6
As an update, I have successfully set up SJphone on Mac 10.4.10 (easy - first time, although in the instructions supplied, the final window does not auto open and you have to select "initialisation" to manually enter your acc number & password).

Still no luck with X-lite, although at least I now have an outgoing facility!

#7
I think the bit that may be missing from your configuration is the NAT port number.

In X-Lite's Account tab, under the Domain Proxy section, tick "Register with domain and receive incoming calls", select "Send outbound via: PROXY" and enter the following address in the box:

nat.voipfone.co.uk:5065

Everything else looks correct on your configuration. I'm also running X-Lite 3.0 on OS X 10.4.10 and it works fine for me.

Robert

Who is online

Users browsing this forum: No registered users and 1 guest

Copyright 2004 - 2017, iNet Telecoms® Ltd. All rights reserved.


cron