Setting up the BT homehub for use with Voipfone

#1
Please note: The BT Home Hub works well with Voipfone when you add your own SIP telephone or adapter. However, it does need the NAT Proxy added. See: http://www.voipfoneuserforum.com/viewtopic.php?t=2707

You only need to follow the procedures below if you are trying to configure the Hub's own telephone port to use a Voipfone account.



This assumes you have firmware 6.2.2.6
This is NOT recommended novices and I accept no responsibility if you break your homehub in the proccess

If your Homehub is Your main router.

1) Goto

http://www.homehubhacks.co.uk/index.php?n=HowTo.GetRoot
use the Script Subsystem Method

2a) telnet into the homehub as the newly created superuser.



Type the following

Code: Select all

voice profile add
then enter the following

SIP_URI = nnnnnnn (this is your SIP ID)
[username] = nnnnnnn (this is your SIP ID again )
[password] = ******** (your password for voipfone)
[password] = ********
[display name] = (whatever you want as your name)
voiceport = (I use COMMON, you can select using up/down arrows, that way it rings all the phones)
[abbr] = (nothing is needed here, not sure what it is)

now type:

Code: Select all

voice sip config primproxyaddr=sip.voipfone.co.uk
voice sip config primregaddr=sip.voipfone.co.uk
voice sip config notifier_addr=sip.voipfone.co.uk
voice sip config regexpire=60
config save filename=user
Taken from the instructions on http://www.homehubhacks.co.uk and modified to suit voipfone


If you want to use another router and just have the homehub acting as a client do the following

1b)
Disconnect from your other router and connect to the homehub

Login to the homehubs web interface, and disable DHCP
Its under Advanced > Ip addresses.

Disable wireless unless you wish to use the Hub as a wireless ap (not sure if it works as an AP as i have mine disabled) the setting is advanced > wireless


Follow the guide at http://www.homehubhacks.co.uk/index.php ... Internally substituting the 192.168.1.1 address for the address of the router.

After saving log out of the homehub, reconnect back to your existing router connect lan1 of the homehub to your router with cat5 utp cable.

Reboot the hub (powercycle it)

3a)
If you wish to disable Key 5 on any phones from switching to the PSTN telnet into the home hub with the superuser login

Enter the following command.

Code: Select all

voice dialplan delete 5
config save filename=user
If you wish to set a key to switch to pstn I believe its (not 100% sure as theres no PSTN connected to mine)

Code: Select all

voice dialplan add x
(where x is the number/code you wish to use to switch ports)

set the port to FXO and leave the other settings on deafult

then enter

Code: Select all

config save filename=user
4) its probably worthwhile stopping BT from remotely updating the hubs firmware since that could undo the handwork we've just done.
follow the guide here to do that.
http://www.homehubhacks.co.uk/index.php ... AutoUpdate

5) if you setup the Superuser as the deafult of hubhax0r you might want to consider changing the password

Telnet into the homehub and enter the following command

Code: Select all

user config password hubhax0r
this should allow you to change the username/password for the superuser

Make sure the role Field is set to SuperUser

use the command

Code: Select all

config save filename=user
to save the changes
Thats about it, I think a factory reset will probably be able to reset all the changes should you wish to undo them but i've not tried it and am not planning to anytime soon.

Notes:
Thanks to homehubhacks and the authors who provided the hacks

Its probably easier when doing the route though another router hack to have your router on the 192.168.1.xx subnet and to ensure that your router is not 192.168.1.254 so that the homehubs web interface is still accessible on 192.168.1.254

Unless changed the homehubs address is static 192.168.1.254 I used IP QOS and portforwarding on my existing router to insure it gets high priority and voip ports are opened.

If it doesn't work Try looking in the webinterface under telephony and check Enable Telephony: checkbox is ticked and press apply

(its probably doing a config save filename=user from the telnet session to make sure this saves, i do not trust the webinterface to save correctly)

I hope someone finds this usefull and will try to answer any questions to the best of my ability however I am not an expert I got this working by reading the instructions given and by trial and error, it seems to be working fine for me but I make no guarantees that it work for anyone else , however if you have a spare homehub why not give it a shot, could save yourself having to shell out for a ATA adaptor :D
Last edited by dragon2611 on September 23rd, 2007, 11:18 am, edited 6 times in total.

#2
If anyone confirms that this works, I'll make it a sticky

Thanks dragon.
Regards,

Voipfone Customer Services

iNet Telecoms Ltd (Voipfone)
Sovereign House
227 Marsh Wall
London
E14 9SD
United Kingdom

Registered number: 05168033
Vat Registration Number 858850966

Telephone: 020 7043 5555
Fax: 020 7043 5556

Web: http://www.voipfone.co.uk
Blog: http://www.voipfoneblog.co.uk
Forum: http://www.voipfoneuserforum.co.uk
Twitter: http://www.twitter.com/voipfone

Homehub phone stops registering

#4
I followed the instructions above around a month ago and all went perfectly - working service, no trouble. However a couple of days ago, the phone lost its registration with voipfone. The dialtone is now the standard POTS dialtone.

I've done a reset on the hub and re-entered all the info exactly as stated above (and that worked before), but still no joy - the URI is showing as "Not Registered". I can ping sip.voipfone.co.uk no problem, and traceroute looks fine too.

Can anyone shed any light on what might have happened, and if it's resolvable?

Re: Homehub phone stops registering

#5
neilwd wrote:I followed the instructions above around a month ago and all went perfectly - working service, no trouble. However a couple of days ago, the phone lost its registration with voipfone. The dialtone is now the standard POTS dialtone.

I've done a reset on the hub and re-entered all the info exactly as stated above (and that worked before), but still no joy - the URI is showing as "Not Registered". I can ping sip.voipfone.co.uk no problem, and traceroute looks fine too.

Can anyone shed any light on what might have happened, and if it's resolvable?
I enabled the wireless on my hub to act as a repeater for a friends laptop which was to old to support the WPA on my main wi-fi access point
Although That worked I stupidly hit save on the web interface and that seemed to corrupt the config as when I powered my hub up this morning it was back on factory deafult settings....

Just noticed a problem with my instructions the line
voice sip config regexpire=60 was incorrect I had written voice sip config config regexpire=60 by mistake its corrected now :lol:

But mines not registering either currently :shock:

Edit: working now :D

I reset the hub with system reset and started again. Put all the settings in for the hack and noticed it wasn't working

Went into the web interface and > telephony then noticed enable telephony wasn't ticked ticked it hit apply and voilla working

Once i done that i did config save filename=user rather than trust the webUI to save the config.

#6
Hmm, interesting - the web UI on my HH also shows telephony not enabled. I checked the box, applied the changes and then did a config save directly, as you did.

However it's made no difference :(

#7
neilwd wrote:Hmm, interesting - the web UI on my HH also shows telephony not enabled. I checked the box, applied the changes and then did a config save directly, as you did.

However it's made no difference :(
How odd.

if you dont mind starting over again perhaps do

system reset
press yes to everything.

Also what I did was download the softphone to makesure i could sign-in to voipfone with that so i knew if it was the hub or something else.

Re: BT HomeHub V6.2.6E

#9
gatsoman wrote:I've been trying to set the NAT for Voipfone on my HomeHub but I have V626E which doesn't allow me to telnet into it.

Does anyone have any ideas as to how I can get my SIP phone to work on I/C calls with Voipfone?

Thanks,

Jerry
Are you trying to use the HUB itself for Voipfone or have you got a SIP phone plugged into it.

These instructions were for hacking the hub to be a SIP phone/ata itself... although they only work on 6.2.2.6 and not the newer firmwares.

If your having trouble with the NAT and a seperate sip phone/voip ata you need to look at hte port forwarding settings.

Hope that helps.

Re: Setting up the BT homehub for use with Voipfone

#11
resolution wrote:Hi Dragon, do you know if it is possible to use the BT phone supplied with the BT Homehub as a standalone phone with mny VOIP account by configuring it as another extension to my VOIPfone pbx?
I am no techy so it will need to be a simple work round, but I notice from the hand book and other forum topics that the hand set is a Thomson product.
Not sure depends if you could setup the hub to connect to the PBX.
Haven't got the hub anymore so can't try :(

Who is online

Users browsing this forum: No registered users and 0 guests

Copyright 2004 - 2017, iNet Telecoms® Ltd. All rights reserved.


cron