New user - No audio on received calls

#1
Hi,

Just set up an account and installed X-lite, works fine for outbound calls. Inbound calls have no audio in either direction, although the soft-phone rings & answers OK. I tried to search the forum for this problem but couldn't find anything. Apologies if this has been answered already. I tried port-forwarding ports 5004-5060 from my router to my PC, still no audio on inbound calls.

Thanks for your help,

AP

#2
If your getting one-way or no audio problems, the best first step is to configure the Outbound Proxy in X-Lite as nat.voipfone.co.uk:5065

Alternatively, if it's already configured, remove it (as it has been known to cause the problem in some configurations).

#3
That's pretty much always a firewall issue. Check this:

http://www.voipfoneuserforum.com/viewtopic.php?t=784
Regards,

Voipfone Customer Services

iNet Telecoms Ltd (Voipfone)
Sovereign House
227 Marsh Wall
London
E14 9SD
United Kingdom

Registered number: 05168033
Vat Registration Number 858850966

Telephone: 020 7043 5555
Fax: 020 7043 5556

Web: http://www.voipfone.co.uk
Blog: http://www.voipfoneblog.co.uk
Forum: http://www.voipfoneuserforum.co.uk
Twitter: http://www.twitter.com/voipfone

#4
voipfone wrote:That's pretty much always a firewall issue. Check this:

http://www.voipfoneuserforum.com/viewtopic.php?t=784
Thanks, I already read this though. I have no software firewall, just an SMC Barricade hardware router & firewall. As suggested in your link above, I configured ports 5004-5060 to forward to the same ports at my Pc's IP address.

Also, as suggested above, I had the outbound proxy configured as nat.voipfone.co.uk:5065, so I tried removing it. No difference, so I put it back in. I tried rebooting the router, no difference.

Actually, I have a Mediatrix 1102 Sip adapter that I intended to configure up once I tried the service with X-lite, but am now beginning to wonder if I should just set up this box as a DMZ off the router. Would ideally like to get the software phone to work first.

Any suggestions appreciated.

Cheers, AP

#5
voipfone wrote:That's pretty much always a firewall issue. Check this:

http://www.voipfoneuserforum.com/viewtopic.php?t=784
Actually i am now getting a bit confused about some of the settings on my X-lite installation and am wondering if some settings are remaining from a previous installation.

If I click on X-lite, then press F8, the settings are as per your recommendation for manual setup. However if I click Menu, System settings, network, the Outbound SIP proxy is set as sipproxy.pipecall.com, stunserver is set as stunserver0.pipecall.com:10000

I used to have a pipecall account, so I'm not sure whether Pipecall became Voipfone, and therefore these settings are correct, or if they are just remaining from my last installation.

#6
Your best bet is to uninstall all versions of the X-Lite and reinstall using the wizard. You'll find a copy here:

http://www.voipfoneuserforum.com/viewtopic.php?t=1092
Regards,

Voipfone Customer Services

iNet Telecoms Ltd (Voipfone)
Sovereign House
227 Marsh Wall
London
E14 9SD
United Kingdom

Registered number: 05168033
Vat Registration Number 858850966

Telephone: 020 7043 5555
Fax: 020 7043 5556

Web: http://www.voipfone.co.uk
Blog: http://www.voipfoneblog.co.uk
Forum: http://www.voipfoneuserforum.co.uk
Twitter: http://www.twitter.com/voipfone

#7
voipfone wrote:Your best bet is to uninstall all versions of the X-Lite and reinstall using the wizard. You'll find a copy here:

http://www.voipfoneuserforum.com/viewtopic.php?t=1092
Have done this, however the settings seem to remain the same. I guess there is a file somewhere that is not being removed by the uninstall. Would be useful if you could let me know what these settings should be. (i.e. Not the F8 settings, but the "Menu - System settings - Network" settings.)

Tried replacing Out Bound SIP Proxy with nat.voipfone.co.uk:5065 and primary STUN server with stun.voipfone.co.uk, but this does not make any difference and I'm not sure these are correct.

Perhaps this is all a red herring in any case and its a firewall issue after all....

Thanks, AP

#8
I dont know if VoIP have a stun server or not, but counterpath (the makers of X-Lite do)

its stun.counterpath.com

Charlie
If you got any questions I'll be happy to help. Just don't ask me about VoIP, i know so little about that i'd bore you trying to talk about it, but we all have to learn sometime!
http://www.wellandpower.net

Who is online

Users browsing this forum: No registered users and 0 guests

Copyright 2004 - 2017, iNet Telecoms® Ltd. All rights reserved.


cron