Using Nokia e60 as your sip phone - good news and bad news

#1
The good news is that I easily got my E60 to work on Sipgate, following the easy to use instructions on setting up on a Nokia handset (you have to be a registered user to see these instructions).
The bad news is I have tried to translate these to voipfone settings, but the phone still fails to register with 'service not available'.
Hopefully the following is nearly right, and I have just made a silly mistake..
I am using the following settings:
On phone go to menu>tools>settings->connection>SIP settings
Create profile Voipfone as follows:

* Service profile: IETF
* Default Access Point: your home wifi
* Public username: sip:3xxxxxxx@voipfone.co.uk
* Use compression: no
* Registration “when needed”
* Use security: no
* Proxy server:
+ Proxy server address: sip.voipfone.co.uk
+ Realm: voipfone.co.uk
+ Allow loose routing: yes
+ Transport type: UDP
+ Port :5060
* Registrar server:
+ Registrar server addr.: sip:sip.voipfone.co.u
+ Realm: voipfone.co.uk
+ Username: 3xxxxxxxx
+ Password: ****
+ Transport type: UDP
+ Port :5060
Now go to connection> Internet Tel. Settings &
* Select new profile
* Select profile just created from list as SIP URI:

Now set preferred internet profile with menu> Connect.> Interet tel.[/list]

#2
please try the following

* Service profile: IETF
* Default Access Point: your home wifi
* Public username: sip:3xxxxxxx@voipfone.co.uk
* Use compression: no
* Registration “when needed”
* Use security: no
* Proxy server: 195.189.173.10
+ Proxy server address: sip.voipfone.co.uk
+ Realm: voipfone.co.uk
+ Allow loose routing: yes
+ Transport type: UDP
+ Port :5060
* Registrar server: 195.189.173.10
+ Registrar server addr.: sip.voipfone.co.uk
+ Realm: voipfone.co.uk
+ Username: 3xxxxxxxx
+ Password: ****
+ Transport type: UDP
+ Port :5060
Now go to connection> Internet Tel. Settings &
* Select new profile
* Select profile just created from list as SIP URI:
Regards,

Voipfone Customer Services

iNet Telecoms Ltd (Voipfone)
Sovereign House
227 Marsh Wall
London
E14 9SD
United Kingdom

Registered number: 05168033
Vat Registration Number 858850966

Telephone: 020 7043 5555
Fax: 020 7043 5556

Web: http://www.voipfone.co.uk
Blog: http://www.voipfoneblog.co.uk
Forum: http://www.voipfoneuserforum.co.uk
Twitter: http://www.twitter.com/voipfone

#3
the
* Proxy server: and
* Registrar server:
are headings, so I can't enter the IP and FQDN at the same time, but I have tried replacing the FQDN with the IP address in both places, but get the same failure - takes a couple of seconds the first time, then is pretty well instant after that. :(

Everything else is the same right?

#4
ok can you post your current config again so i can take another look for you
Regards,

Voipfone Customer Services

iNet Telecoms Ltd (Voipfone)
Sovereign House
227 Marsh Wall
London
E14 9SD
United Kingdom

Registered number: 05168033
Vat Registration Number 858850966

Telephone: 020 7043 5555
Fax: 020 7043 5556

Web: http://www.voipfone.co.uk
Blog: http://www.voipfoneblog.co.uk
Forum: http://www.voipfoneuserforum.co.uk
Twitter: http://www.twitter.com/voipfone

#5
In your first post, you've got the Registrar server address as a full SIP URI:
sip:sip.voipfone.co.uk

but the Proxy server address as a simple FQDN:
sip.voipfone.co.uk

I don't know which one's correct, but shouldn't they both be the same form?

#6
Sorry been away for a few days: here we go, pretty much unchanged from original, the app tends to stick sip: on front of servers adresses I've noticed...

* Service profile: IETF
* Default Access Point: your home wifi
* Public username: sip:3xxxxxxx@voipfone.co.uk
* Use compression: no
* Registration “when needed”
* Use security: no
* Proxy server:
+ Proxy server address: sip:sip.voipfone.co.uk
+ Realm: voipfone.co.uk
+ Allow loose routing: yes
+ Transport type: UDP
+ Port :5060
* Registrar server:
+ Registrar server addr.: sip:sip.voipfone.co.u
+ Realm: voipfone.co.uk
+ Username: 3xxxxxxxx
+ Password: ****
+ Transport type: UDP
+ Port :5060

#7
I'm trying to get this working on VOIPFONE as well at the moment. Got it working on AQL (well for outbound) no probs but then they send you a very nice confuguration text message. However, I want to use VOIPFONE as the features are better.

The E60 does indeed put SIP: automatically on the front of:

Public Username, Proxy Server & Registrar server

Could it be this that it causing the problem with voipfone?

#8
I've noticed that the service provided I have managed to get the E60 to work with is using a different proxy from the regular proxy it uses for XLite PC clients.

Looks like they may be doing something special to account for the E60.

#9
Im keen to see if the E60 or any other Nokia will work on WiFi. Having used the UTStar 1000 and 1000G now for a while, which means carrying my mobile and the wifi, but hey, the WiFi has saved me some cash when on the continent. Particularly calling the office on the same Voip network, which cost nothing of course, along with the 1p or so a minute to UK landlines. I call mobiles through an office ATA gateway.

Nice to know the E60 does work with some providers.

Phil

These settings IMHO "should" work

#11
After reviewing the settings of the provider I have managed to get this to work with and scouring the voipfone website and others I believe the following to be the settings for the E60 that "should" work with voipfone .... but they don't!!

* Service profile: IETF
* Default Access Point: my home wifi
* Public username: sip:3xxxxxxx@voipfone.co.uk
* Use compression: no
* Registration “when needed” or "always" ("when needed" better for testing different settings, "always" better for operation)
* Use security: no
* Proxy server:
+ Proxy server address: sip:nat.voipfone.co.uk (E60 doesn't support NAT so need a proxy)
+ Realm: voipfone.co.uk
+ Allow loose routing: yes
+ Transport type: TCP
+ Port :5065
* Registrar server:
+ Registrar server addr.: sip:sip.voipfone.co.uk
+ Realm: voipfone.co.uk
+ Username: 3xxxxxxxx
+ Password: ****
+ Transport type: UDP
+ Port :5060

I do however now get a different response. It used to hang for a long time trying to register. It now comes back after a sensible time with a "service not available" message ... rather than a "registration failed" message after a long period.

It would be very useful if someone from voipfone could come back with a view on this as IMHO supporting these new convergent GSM/SIP phones is a must for any service provider ... IMHO I think you've been quiet and slow to address the E series phones compared to other providers.

I want to use voipfone due to the better telecom services built around the PBX however I will use the other provider if I can't get this to work.

#15
Just a thought now as i was starting to configure my E61 for voip. The account you are using on the E series, is it all ready registered using a VOIP ATA as this may cause problems with try to have two devices registered on one account.

cheers
deano

#16
Nope this is the only phone registered.

Personally I believe if you don't want to run proprietary software on the phone, this is the Truphone approach, - then you need to do something special behind the proxy to account for the lack of a STUN or ICE client on the phone.

After a few teething problems I actually have this working well with another service provider (basic VOIP) now ... trouble is I'd prefer to use Voipfone as the added telephone services are much better.

#17
I have a Nokia N95 that is working perfectly. Although we have our own trixbox, the set-up should be identical... Have you tried using just the IP address instead of the FQDN?

Who is online

Users browsing this forum: No registered users and 1 guest

Copyright 2004 - 2017, iNet Telecoms® Ltd. All rights reserved.


cron