Snom Dial Plan

#1
I'm confused as to how the snom dial plan works. I managed to set all of our pap2's up fine with dialling plans, all seems straightforward, but the snom baffles me. I downloaded their FAQ user guide on dialling plans but it's somewhat ambiguous.

My current dialling plan looks like this:

|^([a-zA-Z]+:.*)$|\1\2| |^([a-zA-Z0-9&=+\$,;?\-_.!~*'()%]+@.+)|sip:\1| |^([a-zA-Z0-9&=+\$,;?\-_.!~*'()%]*)$|sip:\1@\d|

How would I incorporate a local area code into it eg 01472 like you can with then linksys dialling plan.

I'd also like to be able to use the dialling plan to stop the user form having to press the tick when they wish to make a call and instead the call just dials directly. I believe it's the 'd' that does this?

Also how can I block certain numbers like 090*** numbers and allow emergency service numbers to dial

Any help on this would be greatly appreciated so I can add a bit of uniformity to our office.

Cheers

T :P

#2
This is the Snom dialplan we use:
|(^0[1-9][0-9]{9}$)|sip:\1@\d|d

It means that regular UK 11-digit numbers will dial automatically (ie you don't have to press the tick or OK button), but all others require you to confirm manually or wait for the timer to dial it by default.

I didn't think that Voipfone allowed either 090*** or emergency service numbers at present ...

#4
Hmm.

The Snom whitepaper says that multiple dial plan entries can be separated by spaces ...

I've not tried it, but you could try adding this to the dialplan (separated from the other by a space):

|(^[1-9][0-9]{5}$)|sip:\1@\d|d

This says "match any number starting with the digits 1-9, followed by 5 digits selected from 0-9".

You may need to have this entry first rather than second - try it out.

#5
Okay cool the first one works great thanks David :-D

Where abouts would I enter my area code in the second one so that it knows what to prefix the 6 digit number with?

|(^[01472][1-9][0-9]{5}$)|sip:\1@\d|d

Would it look something like this?

Cheers

T :?

#6
Nope - you'd need:

|(^[1-9][0-9]{5}$)|sip:01472\1@\d|d

The bit between the first two "|" is the keypresses you're matching. The next bit is what to do with it.

#8
EDITED 11/02/2014: SEE MY POST FURTHER DOWN FOR AN UPDATED DIAL PLAN!

This is a full uk dial plan for use with voipfone only, it will dial out local numbers so it saves you having to enter your local area code everytime you call joe bloggs down the road. Simply change the 01792 to your local area code and your set to go!

(If your local area code is 4 digits instead of 5 for example 0121 then you need to change this part {5}$)|sip: which is located infront of your local area code to {6}$)|sip: and your done!)
For everything VoIP
www.ukvoipforums.com

#12
Mathew wrote:I have a snom 360 and cant find anything on the software accessed via the browser regarding the dial plan please help???? Iam trying to add in the dial plan
It's under the SIP tab of the Identity you wish to add a dial plan for
Image
It works perfectly for me on my Snom 360 BTW.

Mark.

#14
Mathew wrote:Mark thank you its all so simple when you are in the know
You're welcome, I've been on voip for less than a week so all knowledge I've gained is from others :)


Mark.

Is this plan OK for placing international calls?

#15
Hi there, First off, thanks to acoolwelshbloke for posting the dial plan (back in August)
It works really well for us for calling UK numbers.
But when we call international numbers (prefixed 001) nothing happens!!
Is there something in the dial plan that prevents long-distance calls?
Or should I look for a different problem.
Yours in total ignorance!
Cheers

#16
You should still be able to dial any numbers (like international numbers) that don't match entries in the dial plan, but you need to tell the phone that you've finished dialing.

If you're dialing with the handset on-hook, simply picking up the handset will make it dial.

If you've picked up the handset to dial, you'll need to press "OK" (on 190s/Elmeg 290s) or the tick button (on other Snoms).

#17
Thanks David - that's what I thought would happen.

To rule out the dial plan as the culprit I have since deleted it and then retried international numbers, but they still don't work.

I'll contact support and let you know what the answer turned out to be.
Cheers

#20
Thought I'd let you know that we resolved the international numbers problem by restoring the phones to factory settings.

Now they work fine - even with the dial plan installed.
Voipfone support were very helpful throughout - and patient!

Re: Snom Dial Plan

#22
OK for whatever reason I wasn't notified of any replies to this post! :oops:
hornma wrote:Is there a easy way with the dial plan to stop numbers being dialed ? I have one for home use.. and would like to block the dialing of mobile numbers ?
Yes!

Code: Select all

|^(07[0-9])$|sip:blocked\@\d|d
Add the above to the end of your dialplan!
Richy wrote:Hi there, First off, thanks to acoolwelshbloke for posting the dial plan (back in August)

It works really well for us for calling UK numbers.

But when we call international numbers (prefixed 001) nothing happens!!

Is there something in the dial plan that prevents long-distance calls?

Or should I look for a different problem.

Yours in total ignorance!

Cheers
I have updated the dial plan to include international numbers (This pattern requires that the user presses the Ok or # key in order to start the call), make the phone dial a number when the pound key is pressed and block calls to 09 premium rate numbers!

Code: Select all

"|^(1[0-5]{2})$|sip:\1@\d|d""|^(166)$|sip:\1@\d|d""|^(999)$|sip:\1@\d|d""|^(1[4-5]7[1-9])$|sip:\1@\d|d""|^(116[0-9]{2})$|sip:\1@\d|d""|^(118[0-9]{2})$|sip:\1@\d|d""|^([2-8][0-9]{5})$|sip:01792\1@\d|d""|^(0[1-9][0-9]{9})$|sip:\1@\d|d""|^00([0-9]*)$|sip:+\1@\d""|^(09[0-9])$|sip:blocked\@\d|d""|^\*\*(2[0-9]{2})$|sip:**\1@\d|d""|([^#]+)#|sip:\1@\d|d"
Make sure you change the 01792 area code in the above to your area code though...

If your area code has four digits make sure you change the {5} just before the 01792 in the dial plan above to {6} and if you have a three digit area code change that {5} to a {7}

Hope this helps
For everything VoIP
www.ukvoipforums.com

Who is online

Users browsing this forum: No registered users and 0 guests

Copyright 2004 - 2017, iNet Telecoms® Ltd. All rights reserved.


cron