Asterisk IAX server problem?

#1
Hi to all
Iam trying to communicate between two asterisk servers using IAX protocol. Details are
SERVER 1 IP address-192.168.0.54
Clients 949 and 950

iax.conf:-
[general]
port=5036
bindaddr=0.0.0.0
disallow=all
aloow=ilbc
allow=ulaw
allow=alaw
iaxcompat=yes
bandwidth=low



register => asterisk1:ashok@192.168.0.11:5036
tos=lowdelay

[asterisk2]
type=friend
auth=md5
secret=ashok
host=dynamic
context=local
defaultip=192.168.0.11
qualify=yes

extensions.conf:-

[ECP]
exten => 949,1,dial(SIP/949,20)
exten => 949,2,voicemail, u949
exten => 950,1,dial(SIP/950,20)
exten => 950,2,voicemail,u950

exten=>_XXX,1,dial(IAX2/asterisk1:ashok@192.168.0.11/${EXTEN}@local,20)


SERVER 2 IP address-192.168.0.11
Clients 449 and 450

iax.conf:-
[general]
port=5036
bindaddr=0.0.0.0
disallow=all
aloow=ilbc
allow=ulaw
allow=alaw

iaxcompat=yes
bandwidth=low

register =>asterisk2:ashok@192.168.0.54:5036
tos=lowdelay

[asterisk1]
type=friend
auth=md5
secret=ashok
host=dynamic
defaultip=192.168.0.54
qualify=yes

extensions.conf:-

[ECP]
exten =>449,1,MP3Player(/etc/asterisk/01.mp3)
exten=>449,2,dial(SIP/449,20)
exten=>449,3,voicemail,u449
exten=>450,1,dial(SIP/450,20)
exten=>450,2,voicemail,u450

exten => _XXX,1,dial(IAX2/asterisk2:ashok@192.168.0.54/${EXTEN}@local,20)



When i tried to dial 949 from server 2 its working but when i tried to dial 449 from server 1 it is gving error like

AT SERVER 1:

*CLI> Jul 11 12:12:24 WARNING[4832]: chan_iax2.c:6995 socket_read: Call rejected by 192.168.0.11: No authority found
*CLI> Jul 11 12:12:24 WARNING[4832]: chan_iax2.c:6995 socket_read: Call rejected by 192.168.0.11: No authority found
*CLI> Jul 11 12:12:24 WARNING[4832]: chan_iax2.c:6995 socket_read: Call rejected by 192.168.0.11: No authority found
*CLI> Jul 11 12:12:24 WARNING[4832]: chan_iax2.c:6995 socket_read: Call rejected by 192.168.0.11: No authority found

AT SERVER 2:

CLI> Jul 11 12:17:18 NOTICE[4914]: chan_iax2.c:6802 socket_read: Rejected connect attempt from 192.168.0.54, who was trying to reach '449@local'

Can you please suggest me what is the problem

Thanks in advance

Who is online

Users browsing this forum: No registered users and 0 guests

Copyright 2004 - 2017, iNet Telecoms® Ltd. All rights reserved.


cron