Snom 360: Need help with complete factory reset

One of our Snoms is playing up.

I can dial out, I can use the Outlook TAPI dialler but I can't use the phone's address book. It doesn't work whether I use the DIRECTORY button on the phone or the Phone's address book webpage. I get "Not Found <Contact>" or "Service Unavailable".

I've tried updating firmware, rootfile etc. and it didn't fix the problem, but now I'm in a position where my attempts to update or downgrade firmware aren't working.
  • System Information:
    Phone Type: snom360-SIP
    MAC-Address: xxxxxxxxxxxxx
    IP-Address: x.x.x.x
    Kernel Version: snom360 linux 3.25
    Application-Version: snom360-SIP 6.2.3
    Rootfs-Version: snom360 jffs2 v3.36
    Production Information: Mac:xxxxxxxxxxxx;Version:Standard;Hardware:snom360 (MB V1.0_K7,KB V1.0_L2-NC);Lot: 23.01.06
If I attempt an update I get "Loading File", then the screen goes blank and the phone reboots with 6.2.3, the version I last succesfully installed.

I need to do a complete "CMos Reset" type factory restore, reload all the updates & start again. Anyone know how I can do this? Simply resetting the phone under "Advanced" doesn't do it.



I've managed to get a newer beta firmware to load, I tried maybe 10 times and on each occasion the phone's screen blanked out at some point and the phone rebooted using 6.2.3.

On the last occasion it went through, and updated, however I still have the same problem I was getting with 6.2.3 whereby I can't use the phones' address book, I still get "NOT FOUND <CONTACT>".

If I dial the number manually it'll connect, If I dial from the phone's webserver address book I get "UNAVAILABLE <Contact>

What versions of the RootFS and Kernel should we be on with our 6.2.3 firmware?



Please ensure the numbers in your phone book are in there with no @<IP> on the end.

Voipfone Customer Services

iNet Telecoms Ltd (Voipfone)
Sovereign House
227 Marsh Wall
E14 9SD
United Kingdom

Registered number: 05168033
Vat Registration Number 858850966

Telephone: 020 7043 5555
Fax: 020 7043 5556


Customer Services wrote:Please ensure the numbers in your phone book are in there with no @<IP> on the end.
There's no @<IP> on the end, in fact I tried creating some new numbers just to see if there was something corrupt about the existing phone book file. It made no difference.

I added a new phonebook entry of "200", another extension on our system and THAT does work.

All my real contact numbers are stored +44<number> no spaces, no leading 0 on the area code. I tried adding entries without the +44 but with the leading zero on the area code but this didn't work either.

I tried removing my dial plan, copying the dial-plan & settings from an identical phone that works. The only difference between the 2 phones that I can tell, and that I only just noticed, is that the one that works has "Rootfs-Version: ramdisk below v3.31" and the one that doesn't work has "Rootfs-Version: snom360 jffs2 v3.36".


Who is online

Users browsing this forum: No registered users and 1 guest

Copyright 2004 - 2017, iNet Telecoms® Ltd. All rights reserved.