Page 1 of 2

Setting up Nokia E61 smartphone for Voipfone use

Posted: May 24th, 2006, 11:54 am
by grunff
Hi all,

I've just purchased a Nokia E61 which I'm trying to set up for VoIP. It has a built in SIP client, I'm just having difficulty figuring out what proxies need to go where.

In the SIP client configuration, I have the following fields to populate:

Service profile [IETF : 3GPP]
Public username [my Voipfone username]
Use compression [Yes : No]
Registration [When needed : Always on]
Use security [Yes : No]

Proxy server
>> Proxy server address [sip:voipfone.co.uk]
>> Realm [voipfone.co.uk]
>> User name [my Voipfone username]
>> Password [my Voipfone password]
>> Allow loose routing [Yes : No]
>> Transport type [UDP : TCP]
>> Port [5060]

Registrar server
>> Registrar server address [sip:voipfone.co.uk]
>> Realm [voipfone.co.uk]
>> User name [my Voipfone username]
>> Password [my Voipfone password]
>> Allow loose routing [Yes : No]
>> Transport type [UDP : TCP]
>> Port [5060]

The connection is via WLAN, to a local access point, through my router and out. I know the access point and router are fine, because the PC I'm using to write this works fine through them (running SJPhone).

When I try to connect from the E61, it says Requesting Registration, then Registration Failed.

Any thoughts, help, advice?

TIA

Posted: May 24th, 2006, 3:33 pm
by davidgu
I've not seen the E61, so this is a bit of a guess ...

First off, you need to be sure that your E61 can connect through the WLAN access point to something else (there's little point trying to set up the VoIP connection if we can't be sure that the underlying WLAN connection is working for the phone). If there's an internet browser on the phone, try that first. Assuming this does work:

There's some settings for the E60 at this address:
http://www.newlc.com/Using-SIP-with-Nok ... 0-and.html

If you search in the Nokia discussions board, you'll find plenty of other folks struggling with the SIP client on the E60 and E61:
http://discussions.nokia.co.uk/discussions/

Posted: May 24th, 2006, 3:41 pm
by grunff
davidgu wrote: First off, you need to be sure that your E61 can connect through the WLAN access point to something else (there's little point trying to set up the VoIP connection if we can't be sure that the underlying WLAN connection is working for the phone). If there's an internet browser on the phone, try that first. Assuming this does work:
Yup, it connects fine - I can browse and do email no problem.

davidgu wrote: There's some settings for the E60 at this address:
http://www.newlc.com/Using-SIP-with-Nok ... 0-and.html
Thanks, I'd found that, but the problem is I don't know which Voipfone settings to use for the SIP proxy and the registrar proxy. For instance, I have 2 different proxy addresses:

SIP proxy: voipfone.co.uk
Outbound proxy: nat.voipfone.co.uk:5065

Should one of these be entered into the "SIP proxy" field and another into the "Registrar proxy"? What is the difference between the two addresses?

Thanks for your help.

Posted: May 24th, 2006, 4:06 pm
by davidgu
I'd enter just "voipfone.co.uk" in both the E61 Sip Proxy and Registrar sections.

You only need "nat.voipfone.co.uk" if you end up with one-way audio or one-way calling.

Posted: May 24th, 2006, 4:18 pm
by grunff
davidgu wrote:I'd enter just "voipfone.co.uk" in both the E61 Sip Proxy and Registrar sections.
You only need "nat.voipfone.co.uk" if you end up with one-way audio or one-way calling.
Thanks. I've tried it, but still no luck, just says "service not available".

Posted: June 3rd, 2006, 7:35 pm
by d.brophy
I've just bought an E61 too! Also having the same problems trying to get it working with voipfone... I've spent half an hour fiddling with the options... No joy.

Posted: June 4th, 2006, 4:21 pm
by grunff
Just to update those interested, I still haven't managed to get it to work. I've spent several hours on it so far with no luck. I've also tried a number of other VoIP service providers, and can't get it to work with any of them.

Nokia support have so far been very lame, "we don't support the SIP client" apparently!

I will post if I find a solution.

Posted: June 4th, 2006, 5:58 pm
by d.brophy
Do you know what the latest firmware should be?

Mine is:
1.0610.04.04
19-04-06
RM-89

(you get this by typing *#0000#).

Posted: June 4th, 2006, 7:07 pm
by grunff
I have the same firmware. I don't know if a later one exists.

E61

Posted: June 12th, 2006, 2:43 pm
by fharr
The last posts on the subject (Nokia E61 or E60 configuration for Voipfone) were in March, with no-one reporting success. Anyone had any luck since then?

Re: E61

Posted: June 12th, 2006, 2:46 pm
by grunff
fharr wrote:The last posts on the subject (Nokia E61 or E60 configuration for Voipfone) were in March, with no-one reporting success. Anyone had any luck since then?
No, they were in June. And no, I still haven't had any success. Nokia have been *extremely* unhelful in helpful in the matter.

I can confirm that I've now tried 3 other SIP providers, all with the same results.

Posted: June 12th, 2006, 2:52 pm
by fharr
oops. Looking at the wrong date(s). But yes -- same experience. I've tried two others. My own pet conspiracy theory is that Vodafone -- my carrier -- is selling VoIP disabled units. :)

Posted: July 21st, 2006, 3:34 pm
by MrHawkie
I've just got the Nokia E70 and am having a similar lack of success getting VOIP to work.

Looking at http://discussions.nokia.co.uk/discussi ... format=all
it seems to be that the Nokia software only likes to talk to servers on the same network.

There are also reports in that forum that VoipTalk works successfully. Perhaps they've implemented something that Voipfone could look into?

Posted: July 21st, 2006, 4:52 pm
by Voipfone Support
just out of interest have you tried registering it to SIP proxy: sip.voipfone.co.uk and if your able to specify a outbound proxy
Outbound proxy: nat.voipfone.co.uk:5065

Posted: July 29th, 2006, 3:01 pm
by mjlaris
I'm trying to get my Nokia E60 phone to register with Voipfone.com and I've tried many different settings but I can't get it to work. The problem with all of the E-series phones is that Nokia did not provide support for NAT traversal (an upgrade to support STUN is coming by the end of the year). Therefore, I need a VoIP provider that supports reverse NAT detection. I have my phone working with VoIPtalk.org but prices are much better on Voipfone so I'd really like to switch if I can get it working. My phones settings are as follows:

Profile name: Voipfone
Service Profile: IETF
Default Access point: *my wifi access point*
Public user name: sip:voipfone_ID@voipfone.co.uk
Use compression: No
Registration: On demand
Use security: No

Proxy server
Proxy server address: sip:nat.voipfone.co.uk
Realm: nat.voipfone.co.uk
User name: voipfone_ID
Password: *my voipfone password*
Allow loose routing: Yes
Transport Type: UDP
Port:5065

Registrar Server
Registrat serv. addr.: sip:sip.voipfone.co.uk
Realm: sip.voipfone.co.uk
User name: voipfone_ID
Password: *my voipfone password*
Transport Type: UDP
Port:5060

If anyone has any suggestions, please let me know.

Mark

Posted: January 1st, 2007, 1:41 pm
by E61DRC
I have the latest firmware on my Nokia E61 (3.0633.09.04) and cannot get the E61 to work with Voipfone. The latest firmware is supposed to improve VoIP. Has anyone got any ideas?

Posted: January 1st, 2007, 2:09 pm
by mjlaris
Post your settings and I'll take a look. The version 3 firmware supports STUN so, in theory, it should work with the correct settings.

Mark

Posted: January 1st, 2007, 2:33 pm
by E61DRC
Thanks. Have tried various possibilities (including the settings in your earlier post with NAT in the proxy server settings). These are the settings I think should work but do not:

Profile name: Voipfone
Service Profile: IETF
Default Access point: *wifi access point*
Public user name: sip:voipfone_ID@voipfone.co.uk
Use compression: No
Registration: When needed
Use security: No

Proxy server
Proxy server address: sip:sip.voipfone.co.uk
Realm: sip.voipfone.co.uk
User name: voipfone_ID
Password: *my voipfone password*
Allow loose routing: Yes
Transport Type: UDP or Auto
Port:5060

Registrar Server
Registrat serv. addr.: sip:sip.voipfone.co.uk
Realm: sip.voipfone.co.uk
User name: voipfone_ID
Password: *my voipfone password*
Transport Type: UDP or Auto
Port:5060

I can connect to Sipgate using the E61 (with the V3 firmware and the V2 firmware). Any suggestions would be most welcome.

Posted: January 1st, 2007, 5:20 pm
by mjlaris
The settings certianly look correct. Have you tried leaving the Proxy server settings blank, sometimes that works. I cannot think of anything else to try. I was never able to get Voipfone to work for me but I have an E60 and am therefore still on version 2 of the firmware. Let me know if you get it to work.

Mark

Posted: January 1st, 2007, 7:48 pm
by E61DRC
I have just tried leaving the proxy server settings blank, but it did not work. Well may be the next version of the firmware (V4?) will work. The latest firmware added support for STUN, and later firmware will add support for TURN and ICE. If we knew what the problem was then we would know if this might help.

Posted: January 1st, 2007, 8:16 pm
by mjlaris
We not only don't know what the problem is but we don't know how Nokia implemented STUN in version 3 of the firmware. I was expecting a new setting under SIP settings where you could add an Outbound Proxy server address or something equivalent. I'd settle for knowing exactly how the firmware handles STUN.

Another thought just occurred to me, do you have your home service registered with Viafone? You probably cannot have two devices registered with the same phone number at the same time.

Mark

Posted: January 2nd, 2007, 9:09 am
by E61DRC
The only device I am using for VoIP is the E61 so having two devices registered is not the problem.

There is some information about the S60 VoIP client here:
http://www.forum.nokia.com/main/resourc ... index.html
Nokia seem to want to minimise the settings that consumers can mess about with!

Posted: January 2nd, 2007, 3:10 pm
by mjlaris
Thanks E61DRC, I followed the link and read some of the reports on the forum Nokia site. It confirmed what I has deduced but it's nice to have confirmation.

Mark

Posted: January 4th, 2007, 10:37 am
by E61DRC
I seem to have got Voipfone to work with the E61 by putting asterisk as the realm for the Registrar and Proxy servers!!

Posted: January 4th, 2007, 1:15 pm
by Voipfone
Well, thanks to E61DRC - these setting appear to work

Profile Name: Voipfone
Public Username: XXXXXXXX@195.189.173.10 (xxxxxxxx = your 8 digit voipfone number beginning with 3)

Proxy Server:
Proxy server address: 195.189.173.10
Realm: asterisk
Username: XXXXXXXX (your 8 digit voipfone number beginning with 3)
Password: XXXXXX (your 6 digit password)
Allow loose routing: Yes
Transport Type: UDP
Port: 5060

Register Server:
Proxy server address: 195.189.173.10
Realm: asterisk
Username: XXXXXXXX (your 8 digit voipfone number beginning with 3)
Password: XXXXXX (your 6 digit password)
Allow loose routing: Yes
Transport Type: UDP
Port: 5060